Skip to main content

FV Decipher Support

All the topics, resources needed for FV Decipher.

 
FocusVision Knowledge Base

PowerPoint

About Customizing the PowerPoint Export

When exporting data into PowerPoint, there is a default PowerPoint template which is applied. To customize the look and feel of your project’s template follow the instructions below.

There are two different templates and each template is used by different reporting systems. Report 2010 and Crosstabs share a template called “template.pptx” while Dashboards use a template called “dashboard.pptx”. These are pre-defined names that are looked for explicitly.

Note: In Report 2010 you also have the option to export to ppt, which references “template.ppt”. You can customize “template.ppt” in a similar manner as described here, but you must use PowerPoint 2003 or earlier to edit the file, otherwise there will be errors during the export process. 

The two template files are very similar, but do contain slight differences. Having two different files controlling the look and feel allows for two different styles to be applied between Dashboards and Report 2010/Crosstabs.

To customize a template, download the corresponding file below, edit the contents and upload to your project's root directory.


Here are the templates:

Note: This article has been created using PowerPoint 2013. For other versions of PowerPoint, use comparable menu options.

Editing the Template

Our PowerPoint template will contain text that will pull in survey information dynamically. Below is a description of each of the code snippets you will see in the template. 

1. $(surveyTitle): Name of the project as shown in the portal
2. $(closeDate): Date of Survey close or current date PowerPoint exported
3. [$(label)] $(title): Question label/text
4. [$(label)] $(full): Question label/text for the footer
5. $(base): Question base count
6. Column, Data: Where data is filtered into for tables

Note:  The prefix [$(label)] and $(closeDate) appear only on the template.pptx. The dashboards.pptx will not show these codes.

Step 1: Edit the Table

To edit the color scheme of this table:

1. Select the table.
2. Select Table Tools>Design.
3. Select a new style from the Table Styles menu.

Step 2:  Edit the Background Image

The template uses different background images in the normal view for slide 1 and slide 2. Editing the Slide Master will not override either of these images. You can replace these images with your own images or change them to use different images, gradient colors or solid colors.

To edit the background image:

1. Right-click the background and select "Format Background".
2. Select FILL and choose Solid, Gradient or Picture fill.

Step 3.  Edit the Slide Master.

You can use the Slide Master to change the default size for all slides. To do this, open the template file and navigate to View>Master Views>Slide Master. Once in the Slide Master, go to Slide Size and select either Standard or Widescreen.

After you are finished with your Slide Master edits, go to View>Presentation Views>Normal to return to the default view.

Step 4:  Save the Template

Select File>Save to save your customized template.

Note: Make sure that the filename is saved as either template.pptx or dashboard.pptx, depending on the template type.  

Step 5:  Upload the Template

Upload the template file for your survey to the project's main directory the "System File (root)" folder using the "Upload system files" link from the portal. 

Note:  If you are a shell user and have shell access to your own server, you can upload a template to a client directory which will then be used as the default for all the client directory's projects.

Step 6:  Verify the Template

Export your crosstabs report or dashboard to PowerPoint to verify that the template is customized as desired.
If additional changes are needed, make those changes in your template, and upload the file again to overwrite your previous upload.

Note: If you are encountering errors, check the template's properties to verify that none have been specified. Select File>Properties and be sure the information fields are "blank", especially the "author" field because this is known to cause errors.

  • Was this article helpful?